Setting Up ELGG - FAIL


Like any normal person--normal people don't do this, I know--I spent most of my afternoon knocking on my head on my desk, as if I were deranged, mumbling about what a pain ELGG was to install. You see, yesterday, it was suggested that wouldn't it be neat if the following:

Online community of educators, who were tech-savvy and eager to connect with each other, could meet and work online with their mentor teachers?

I thought it was a worthy goal and asked folks, getting rich feedback from lots of folks, such as (and this is a sample):
To try to get the juices flowing, so to speak, I worked on a quick GoogleDoc, shown below, only to find out others had already done the work! Definitely check out this chart!

Of course, I tried WordPress and BuddyPress but didn't immediately see how to best organize it. I'm holding it in reserve (it installed flawlessly) in case ELGG won't work. The problem with ELGG? Something called ModRewrite.

The problem appears right after this page flies by (deceptively easy to setup if you ever setup Wordpress or Moodle):

The next page tries to go to this URL:
http://website/whereelggis/action/systemsettings/install

After that, I just get a blank page. The instructions--I laugh at that--appear here:

I have mod_rewrite installed, but my install action isn't working!
If you're getting errors on installation like:
Not Found. The requested URL /elgg/action/systemsettings/install was not found on this server
You may need to give mod_rewrite a pointer to where your Elgg installation is.
  • Open up .htaccess in a text editor
  • Where prompted, add a line like RewriteBase /path/to/your/elgg/installation/ (Don't forget the trailing slash)
  • Save the file and refresh your browser.
Please note that the path you are using is the WEB path, minus the host.
For example, if your Elgg install is in:
/home/marcus/public_html/
Your RewriteBase line should look like:
RewriteBase /~marcus/


Of course, enabling .htaccess doesn't work (/etc/apache2/httpd.conf) to AllowOverride All just doesn't work. I start/restart the Web Server (Mac OS X Leopard) to no avail.

So, I'm back to considering Moodle as my tool of choice. Sigh. (can you sense the unasked, desperate pleas for help?)

Subscribe to Around the Corner-MGuhlin.org


Everything posted on Miguel Guhlin's blogs/wikis are his personal opinion and do not necessarily represent the views of his employer(s) or its clients. Read Full Disclosure

Comments

Eric Evans said…
Is this a Windows-based server? What is the web OS (IIS, Apache, etc)?

Popular posts from this blog

#Chromecast Add-Ons to Play Various Video File Formats

Free Professional Learning! Education On Air #googleedu

10 Steps to a Blended Learning Classroom #MIEexpert #MIE #tceamie1